KUMPULAN TUTORIAL MIKROTIK

Winbox/Guinya Mikrotik

Tutorial sederhana ( hanya 3 langkah ) ini sangat bermanfaat bagi RT/RW net atau warnet yang ingin melakukan optimalisasi bandwidth dengan melakukan queue traffic download dari file-file tertentu.

Sudah menjadi masalah klasik ketika bandwidth warnet / RT/RW net harus habis karena ada salah satu client/user rakus bandwidth melakukan downloading . Tentunya dengan simpe queue sederhana hal ini bisa diatasi. Tapi bagaimana jika client awam tetap ingin browsing itu lancar meskipun mereka sedang download file. Client yang aneh …

Berikut tutorial untuk melakukan limitasi bandwidth dari DataUtamaNet untuk melimit traffic download extension file2 tertentu. Disini saya akan memanfaatkan fasilitas content, address list, mangle dan simple queue dari mikrotik. Saya asumsikan Router Mikrotiik sudah terinstall dengan baik, dalam artian client kita sudah bisa akses internet dengan lancar.

Langkah 1 Kita masukan rule di firewall untuk mendapatkan IP dari download server dan memasukan IP tersebut ke dalam address list

/ip firewall filter add chain=forward src-address=192.168.10.0/24 protocol=tcp content=.mp3 action=add-dst-to-address-list address-list=downloads address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.10.0/24 protocol=tcp content=.exe action=add-dst-to-address-list address-list=downloads address-list-timeout=01:00:00

Rule diatas akan menangkap semua traffic dengan content .mp3 dan .exe yang berasal dari blok IP LAN dan memasukannya ke addres list downloads selama 1 jam. Variable diatas dapat dirubah sesuai dengan topology dan kebutuhan anda sendiri.

Langkah 2 Kita lakukan mangle untuk marking paket yang berasal dari address list yang telah kita dapat dari Langkah 1

/ip firewall mangle add chain=forward protocol=tcp src-address-list=downloads action=mark-packet new-packet-mark=download-paket

Mangle ini kita perlukan untuk melabeli paket sehingga simple queue dapat menangkap traffic dari IP-IP yang telah terdapat pada address list “downloads” Langkah 3 Langkah terakhir kita masukkan simple queue dari paket mark yang telah kita dapet dari langkah 2

/queue simple add name=download-files max-limit=64000/64000 packet-marks=download-paket

Letakan queue di urutan paling atas supaya dibaca dulu oleh mikortik That’s it .. Kita sudah berhasil mengalokasikan bandwidth untuk traffic download file2 yang kita inginkan, dan browsing tetap lancar .. meskipun browsing ke server yang sudah pada address list menjadi lambat karena ikut ke limit at least for the next 1 hour

Saya sudah pernah melakukan marking paket dengan memasukan langsung content pada rule mangle tapi pada prakteknya ketika kita mendownload file dengan extension yang sama secara simultan Queue tidak berjalan efektif 100% .

Configurasi Mikrotik dengan ADSL Speedy

This articel i explain how to configuration mikrotik using pc for router.

1. Configuration position of ADSL connection modem —Mikrotik—-Switch —– Client | Client a. Modem IP –>> 192.168.1.1 b. Mikrotik Using 2 Interface – Ether1 —->> 192.168.1.2 – Ether1 —->> 192.168.0.254 c. Switch — Client ip 192.168.0.1-253

2. Configuration step router pc mikrotik

a. add ip address to interface 1 /ip address add interface=ether1 address = 192.168.1.1 netmask= 255.255.255.0

b. add ip address to interface2 /ip address add interface=ether2 address = 192.168.0.1 netmask= 255.255.255.0

c. to see input of interface /interface print

d. Set Value name off interface /inteface set 0 name=”Public” –>> For Modem /inteface set 1 name=”Lan” –>> For Lan

e. set routing for net ( modem ) /ip route add gateway=192.168.0.1

f. set dns server ISP /ip dns set primary-dns=203.130.193.74 secondary-dns=202.134.0.155 /ip dns set allow-remote-requests=yes

g. set of nat the router pc to sharing bw to lan /ip firewall nat add chain=srcnat out-inteface=Public action=masquerade

14 langkah instalasi mikrotik pakai speedy

/ip address add interface=ether1 address = 192.168.1.2 netmask= 255.255.255.0

/ip address add interface=ether2 address = 192.168.0.1 netmask= 255.255.255.0

/interface print

/inteface set 0 name=”Public”

/inteface set 1 name=”Lan”

/ip route add gateway=192.168.0.1

/ip dns set primary-dns=203.130.193.74 secondary-dns=202.134.0.155

/ip dns set allow-remote-requests=yes

/ip firewall nat add chain=srcnat out-inteface=Public action=masquerade

/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect toports= 8080

/ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect toports= 8080

/ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect toports= 8080

/ip pool add name=”dhcp-pool” ranges=192.168.0.1-192.168.0.29

/ip dhcp-server add name=”dhcp1″ inteface=LAN address-pool=”dhcp-pool” lease-time=3d

/ip dns set allow-remote-requests=yes

/ip firewall nat add chain=srcnat out-inteface=Public action=masquerade

/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect toports= 8080

/ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect toports= 8080

/ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect toports= 8080

( http://harrychanputra.wordpress.com )

Hotspot Mikrotik

Begitu mudahnya untuk menggunakan mikrotik. Konsep networking yang sudah anda pahami akan sangat mudah di implementasikan di operating sistem router yang berbasis kepada linux kernel ini. Kali ini kita akan praktekan sebuah judul yang banyak di nanti orang banyak. Judul yang di ambil adalah, membuat hotspot dan user manager dengan router yang sama. Langkah pertama adalah sbb :

1. Buat sebuah server Radius / radius add service=hotspot address=127.0.0.1 secret=123456

2. Buat profile dan set profile tersebut untuk menggunakan Radius Server / ip hotspot profile set hsprof1 use-radius=yes

3. Membuat scriber / tool user-manager customer add login=”MikroTik” password=”qwerty” permissions=owner

4. Tambahkan Router kita dalam hal ini localhost. / tool user-manager router add subscriber=MikroTik ip-address=127.0.0.1 shared-secret=123456 5.

Lalu silahkan browser ke http://routeranda/userman

Tutorial Step By Step Setting Mikrotik

MikroTik RouterOS™ adalah sistem operasi linux yang dapat digunakan untuk menjadikan komputer menjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot. Ada pun fitur2 nya sbb:

* Firewall and NAT – stateful packet filtering; Peer-to-Peer protocol filtering; source and destination NAT; classification by source MAC, IP addresses (networks or a list of networks) and address types, port range, IP protocols, protocol options (ICMP type, TCP flags and MSS), interfaces, internal packet and connection marks, ToS (DSCP) byte, content, matching sequence/frequency, packet size, time and more…

* Routing – Static routing; Equal cost multi-path routing; Policy based routing (classification done in firewall); RIP v1 / v2, OSPF v2, BGP v4

* Data Rate Management – Hierarchical HTB QoS system with bursts; per IP / protocol / subnet / port / firewall mark; PCQ, RED, SFQ, FIFO queue; CIR, MIR, contention ratios, dynamic client rate equalizing (PCQ), bursts, Peer-to-Peer protocol limitation

* HotSpot – HotSpot Gateway with RADIUS authentication and accounting; true Plug-and-Play access for network users; data rate limitation; differentiated firewall; traffic quota; real-time status information; walled-garden; customized HTML login pages; iPass support; SSL secure authentication; advertisement support

* Point-to-Point tunneling protocols – PPTP, PPPoE and L2TP Access Concentrators and clients; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; MPPE encryption; compression for PPPoE; data rate limitation; differentiated firewall; PPPoE dial on demand

* Simple tunnels – IPIP tunnels, EoIP (Ethernet over IP)

* IPsec – IP security AH and ESP protocols; MODP Diffie-Hellman groups 1,2,5; MD5 and SHA1 hashing algorithms; DES, 3DES, AES-128, AES-192, AES-256 encryption algorithms; Perfect Forwarding Secrecy (PFS) MODP groups 1,2,5

* Proxy – FTP and HTTP caching proxy server; HTTPS proxy; transparent DNS and HTTP proxying; SOCKS protocol support; DNS static entries; support for caching on a separate drive; access control lists; caching lists; parent proxy support

* DHCP – DHCP server per interface; DHCP relay; DHCP client; multiple DHCP networks; static and dynamic DHCP leases; RADIUS support

* VRRP – VRRP protocol for high availability

* UPnP – Universal Plug-and-Play support

* NTP – Network Time Protocol server and client; synchronization with GPS system

* Monitoring/Accounting – IP traffic accounting, firewall actions logging, statistics graphs accessible via HTTP * SNMP – read-only access

* M3P – MikroTik Packet Packer Protocol for Wireless links and Ethernet

* MNDP – MikroTik Neighbor Discovery Protocol; also supports Cisco Discovery Protocol (CDP)

* Tools – ping; traceroute; bandwidth test; ping flood; telnet; SSH; packet sniffer; Dynamic DNS update tool Layer 2 connectivity:

* Wireless – IEEE802.11a/b/g wireless client and access point (AP) modes; Nstreme and Nstreme2 proprietary protocols; Wireless Distribution System (WDS) support; virtual AP; 40 and 104 bit WEP; WPA pre-shared key authentication; access control list; authentication with RADIUS server; roaming (for wireless client); AP bridging

* Bridge – spanning tree protocol; multiple bridge interfaces; bridge firewalling, MAC

* VLAN – IEEE802.1q Virtual LAN support on Ethernet and wireless links; multiple VLANs; VLAN bridging

* Synchronous – V.35, V.24, E1/T1, X.21, DS3 (T3) media types; sync-PPP, Cisco HDLC, Frame Relay line protocols; ANSI-617d (ANDI or annex D) and Q933a (CCITT or annex A) Frame Relay LMI types

* Asynchronous – s*r*al PPP dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; onboard s*r*al ports; modem pool with up to 128 ports; dial on demand

* ISDN – ISDN dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; 128K bundle support; Cisco HDLC, x75i, x75ui, x75bui line protocols; dial on demand

* SDSL – Single-line DSL support; line termination and network termination modes

Instalasi dapat dilakukan pada Standard computer PC yang akan dijadikan router dan tidak memerlukan resource yang cukup besar untuk penggunaan standard, misalnya hanya sebagai gateway. Berikut spec_minimal nya :

* CPU dan motherboard – bisa dgn P1 ~ P4, AMD, cyrix asal yang bukan multiprosesor

* RAM – minimum 32 MiB, maximum 1 GiB; 64 MiB atau lebih sangat dianjurkan, kalau mau sekalian dibuat proxy , dianjurkan 1GB… perbandingannya, 15MB di memori ada 1GB di proxy..

* HDD minimal 128MB parallel ATA atau Compact Flash, tidak dianjurkan menggunakan UFD, SCSI, apa lagi S-ATA (mungkin nanti Ver. 3.0)

* NIC 10/100 atau 100/1000

Untuk keperluan beban yang besar ( network yang kompleks, routing yang rumit dll) disarankan untuk mempertimbangkan pemilihan resource PC yang memadai. Lebih lengkap bisa dilihat di http://www.mikrotik.com.

Meskipun demikian Mikrotik bukanlah free software, artinya kita harus membeli licensi terhadap segala fasiltas yang disediakan. Free trial hanya untuk 24 jam saja. Kita bisa membeli software MikroTik dalam bentuk “licence” di CITRAWEB, UFOAKSES, PC24 (atau download cracknya, he he he …) yang diinstall pada HardDisk yang sebelumnya download/dibuat MikroTik RouterOS ISO kekeping CD atau disk on module (DOM). Jika kita membeli DOM tidak perlu install tetapi tinggal pasang DOM pada slot IDE PC kita.

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan sederhana sebagai gateway server.

1. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.

2. Login Pada Mikrotik Routers melalui console : MikroTik v2.9.39 Login: admin Password: (kosongkan) Sampai langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default adalah admin dan tanpa password, tinggal ketik admin kemudian tekan tombol enter.

3. Untuk keamanan ganti password default [admin@Mikrotik] > password old password: ***** new password: ***** retype new password: ***** [admin@ Mikrotik] >

4. Mengganti nama Mikrotik Router, pada langkah ini nama server akan kita ganti menjadi “r-WLI” (bebas, disesuaikan dengan nama jaringan kita…) [admin@Mikrotik] > system identity set name=r-WLI [admin@r-WLI] >

5. Melihat interface pada Mikrotik Router [admin@r-WLI] > interface print Flags: X – disabled, D – dynamic, R – running # NAME TYPE RX-RATE TX-RATE MTU 0 R ether1 ether 0 0 1500 1 R ether2 ether 0 0 1500 [admin@r-WLI] >

6. Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.0.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 172.16.0.1

[admin@r-WLI] > ip address add address=192.168.0.1 / netmask=255.255.255.0 interface=ether1 [admin@r-WLI] > ip address add address=172.16.0.1 / netmask=255.255.255.0 interface=ether2

7. Melihat konfigurasi IP address yang sudah kita berikan

[admin@r-WLI] >ip address print

Flags: X – disabled, I – invalid, D – dynamic # ADDRESS NETWORK BROADCAST INTERFACE 0 192.168.0.1/24 192.168.0.0 192.168.0.63 ether1 1 172.16.0.1/24 172.16.0.0 172.16.0.255 ether2 [admin@r-WLI] >

8. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254

[admin@r-WLI] > /ip route add gateway=192.168.0.254

9. Melihat Tabel routing pada Mikrotik Routers

[admin@r-WLI] > ip route print Flags: X – disabled, A – active, D – dynamic, C – connect, S – static, r – rip, b – bgp, o – ospf # DST-ADDRESS PREF-SRC G GATEWAY DISTANCE INTERFACE 0 ADC 172.16.0.0/24 172.16.0.1 ether2 1 ADC 192.168.0.0/26 192.168.0.1 ether1 2 A S 0.0.0.0/0 r 192.168.0.254 ether1 [admin@r-WLI] >

10. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

[admin@r-WLI] > ping 192.168.0.254 192.168.0.254 64 byte ping: ttl=64 time

11. Setup DNS pada Mikrotik Routers [admin@r-WLI] > ip dns set primary-dns=192.168.0.10 / allow-remoterequests=no [admin@r-WLI] > ip dns set secondary-dns=192.168.0.11 / allow-remoterequests=no

12. Melihat konfigurasi DNS

[admin@r-WLI] ip dns> pr primary-dns: 192.168.0.10 secondary-dns: 192.168.0.11 allow-remote-requests: no cache-size: 2048KiB cache-max-ttl: 1w cache-used: 21KiB [admin@r-WLI] ip dns>

13. Tes untuk akses domain, misalnya dengan ping nama domain

[admin@r-WLI] > ping yahoo.com 216.109.112.135 64 byte ping: ttl=48 time=250 ms 10 packets transmitted, 10 packets received, 0% packet loss round-trip min/avg/max = 571/571.0/571 ms [admin@r-WLI] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

14. Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.

[admin@r-WLI]> ip firewall nat add action=masquerade / outinterface=ether1 chain:srcnat [admin@r-WLI] >

15. Melihat konfigurasi Masquerading

[admin@r-WLI]ip firewall nat print Flags: X – disabled, I – invalid, D – dynamic 0 chain=srcnat out-interface=ether1 action=masquerade [admin@r-WLI] >

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi MikroTik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa didownload dari MikroTik.com atau dari server mikrotik kita. Misal Ip address server mikrotik kita 192.168.0.1, via browser buka http://192.168.0.1 dan download WinBox dari situ.

Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya :

1. Buat IP address pool /ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

2. Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client Pada contoh ini networknya adalah 172.16.0.0/24 dan gatewaynya 172.16.0.1 /ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

3. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface ether2 ) /ip dhcp-server add interface=ether2 address-pool=dhcp-pool

4. Lihat status DHCP server

[admin@r-WLI] > ip dhcp-server pr

Flags: X – disabled, I – invalid # NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP x dhcp1 ether2 dhcp_pool1 4w2d yes [admin@r-WLI] > Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah 5.

5. Jangan Lupa dibuat enable dulu dhcp servernya /ip dhcp-server enable 0 Kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif.

6. Tes Dari client

Run dari Comman Prompt

Microsoft Windows XP [Version 5.1.2600] (C) Copyright 1985-2001 Microsoft Corp.

C:Documents and SettingsEsDat>ping http://www.yahoo.com

Pinging http://www.yahoo-ht3.akadns.net [69.147.114.210] with 32 bytes of data:

Reply from 124.158.129.5: bytes=32 time=34ms TTL=59

Reply from 124.158.129.5: bytes=32 time=24ms TTL=59

Reply from 124.158.129.5: bytes=32 time=41ms TTL=59

Reply from 124.158.129.5: bytes=32 time=29ms TTL=59

Ping statistics for 69.147.114.210: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 24ms, Maximum = 41ms, Average = 32ms

7. Untuk bandwith controller, bisa dengan sistem simple queue ataupun bisa dengan mangle

[admin@r-WLI] queue simple> add name=Komputer01 / interface=ether2 target-address=172.16.0.1/24 max-limit=65536/131072

[admin@r-WLI] queue simple> add name=Komputer02 / interface=ether2 target-address=172.16.0.2/24 max-limit=65536/131072 dan seterusnya… lengkap nya ada disini

http://www.mikrotik.com/docs/ros/2.9/root/queue

linux-ip.net/articles/Traffic…/overview.html

luxik.cdi.cz/~devik/qos/htb

http://www.docum.org/docum.org/docs

Referensi

http://www.mikrotik.com

http://www.mikrotik.com/docs/ros/2.9

hemaya.wordpress.com

Install Router Menggunakan Mikrotik RouterOS

MikroTik RouterOS™ adalah sistem operasi dan yang dapat digunakan untuk menjadikan komputer manjadi router network yang handal, mencakup berbagai fitur lengkap untuk network dan wireless. Kemudian di extrack dan kemudian burn ke CD itu file ISO nya.

1. Install Mikrotik OS – Siapkan PC, minimal Pentium I juga gak papa RAM 64,HD 500M atau pake flash memory 64 – Di server / PC kudu ada minimal 2 ethernet, 1 ke arah luar dan 1 lagi ke Network local

– Burn Source CD Mikrotik OS masukan ke CDROM

– Boot dari CDROM

– Ikuti petunjuk yang ada, gunakan syndrom next-next dan default

– Install paket2 utama, lebih baiknya semua packet dengan cara menandainya (mark)

– Setelah semua paket ditandai maka untuk menginstallnya tekan “I”

– Lama Install normalnya ga sampe 15menit, kalo lebih berarti gagal, ulangi ke step awal

– Setelah diinstall beres, PC restart akan muncul tampilan login

2. Setting dasar mikrotik Langkah awal dari semua langkah konfigurasi mikrotik adalah setting ip

Hal ini bertujuan agar mikrotik bisa di remote dan dengan winbox dan memudahkan kita untuk melakukan berbagai macam konfigurasi

– Login sebagai admin dengan default password ga usah diisi langsung enter

Gantilah dengan ip address anda dan interface yg akan digunakan untuk meremote sementara

Di sini akan saya terangkan dengan menggunakan 2 cara yaitu dengan dengan text dan winbox.

I. Langkah setting Mikrotik TEXT ———————————————— Mari kita mulai dengan asumsi proses install sudah berhasil

1. Install – OK

2. Setting IP eth1 202.154.XXX.XXX (dari ISP) perintah : ip address add address 202.154.xxx.xxx netmask 255.255.255.xxx interface ether1 IP tersebut adalah IP public / IP yang yang ada koneksi Internet

3. Setting IP eth2 192.168.0.100 (terserah ip mana yang mau dipakai) perintah : ip address add address 192.168.0.100 netmask 255.255.255.0 interface ether2 IP tersebut adalah IP Local anda. Sekarang lakukan ping ke dan dari komputer lain, setelah konek lanjutkan ke langkah berikutnya, kalo belum ulangi dari langkah no 2.

4. Setting Gateway perintah : ip route add gateway=202.154.xxx.xxx (dari ISP)

5. Setting Primary DNS perintah : ip dns set primary-dns=202.154.57.34 (dari ISP)

6. Setting Secondary DNS perintah : ip dns set secondary-dns=202.154.1.2 (dari ISP)

7. Setting Routing masquerade ke eth1 perintah : ip firewall nat add chain=srcnat action=masquerade out-interface=ether1

Untuk terakhir lakukan test ping ke Gateway / ke yahoo.com, bila konek maka Mikrotik anda dah siap di gunakan.

II. Langkah setting Mikrotik WINBOX

Untuk setting menggunakan WINBOX anda cukup mengklik tab dengan nama perintah yang sama seperti pada mode TEXT.

Memisahkan traffic download di mikrotik

/ip firewall ma add chain=forward protocol=tcp content=.exe action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=output protocol=tcp content=.exe action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=forward protocol=tcp content=.avi action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=output protocol=tcp content=.avi action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=forward protocol=tcp content=.zip action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=output protocol=tcp content=.zip action=mark-connection new-connection-mark=con-dowloader passthrough=yes comment=”” disabled=no

add chain=output connection-mark=con-dowloader action=mark-packet new-packet-mark=downloader-pkt passthrough=no comment=”” disabled=no

add chain=forward connection-mark=con-dowloader action=mark-packet new-packet-mark=downloader-pkt passthrough=no comment=”” disabled=no

/queue simple add name=”downloader” dst-address=0.0.0.0/0 interface=all packet-marks=downloader-pkt direction=both priority=8 queue=default-small/default-small limit-at=0/64000 max-limit=0/64000 burst-limit=/128000 burst-threshold=/96000 burst-time=/10s total-queue=default-small disabled=no

( Source http://www.forummikrotik.com )

MIKROTIK WIRELESS CONFIGURATION

POINT TO MULTI POINT

SISI BASE STATION

Interface

– eth1

– wlan

– bridge1

wlan setting

Radio-name = nama_radio_base

mode = AP-Bridge

ss-id = rahasia_21

band = 5GHz – freq = 5180

Security Profile = Amankan_dong

Default Autentication = yes

Default Forward = yes

wds setting

wds mode = dynamic

wds de bridge = bridge1

Security Profile Setting

name = Amankan_dong

mode = dynamic key

WPA – PSK = yes

WPA2 – PSK = yes

WPA – Pre-Share-Key = test-dong-passwd

WPA2- Pre-Share-Key = test-dong-passwd

Bridging Setting

interface yang di bridge

– Eth1

– wlan

– wds

ip setting interface yang di setting

ip bridge = 10.17.10.10

SISI CLIENT

Interface

– eth1

– wlan

– bridge

wlan setting

radio-name = nama_radio_client_remote

mode = station_wds

ss-id = rahasia_21

band = 5GHz –

freq = 5180

Security Profile = Amankan_dong

Default Autentication = yes

Default Forward = yes

wds setting

wds mode = dynamic wds de

bridge = bridge1

Security Profile

Setting name = Amankan_dong

mode = dynamic key

WPA – PSK = yes

WPA2 – PSK = yes

WPA – Pre-Share-Key = test-dong-passwd

WPA2- Pre-Share-Key = test-dong-passwd

Bridging Setting

– Eth1

– wlan

ip setting

interface yang di setting

ip bridge = 10.17.10.11

MIKROTIK QoS [bandwidth management]

MIKROTIK QoS

Simple Queue

untuk menggunakan simple Queue

– aktifkan max-limit – upload = 256k

– download = 256k

Simple Queue with Burst

1.aktifkan max-limit

– target address = host address

= max-limit

>> upload = 64k

>> download = 256k

= burst-limit

>> upload = 128k

>> download = 256k

= bust-treshold

>> upload = 32k

>> download = 64k = time burst

>> 20 sec

Queue With Dual Limitation

1. Parent Queue

> aktifkan parent-Queue

– name = main_queue

– max-limit = 256k / 256k >

advance tab = optional

kombinasikan simple Queue with burst dengan menambahkan dual-limitation tau parent-queue [main-queue]

Simple Queue With Time

1. jalankan Simple Queue with Burst

2. aktifkan time range for limit

– office_hours

– after_office_hours

– holiday

Graphing Traffic

1. cara kerja mirip seperti mrtg

Queue Disciplines [Schaduler dan Shapes]

1. Scheduler >

Limit the number of waiting packet

2. Traffic Shapes >

control data flow speed also can do schaduling task

1. contoh Scheduler Queue :

– BFIFO – PFIFO | Byte or Packet

– RED – SFQ

2. contoh Shaper Queue :

– PCQ – HTB

what is :

1. RED ?

2. SFQ ?

3. PCQ ?

Per Connection Queue [PCQ]

1. Memory comsumtive

2. not limit the number sub flow

PCQ-Algorithm

1. jika Limit-at and Max-limit set = 0 maka sub-queue bisa mendapatkan semua bandwidth yang tersedia di paren. artinya mereka bisa menggunakan semua bandwidth secara rata.

Contoh PCQ

MARKING

1. marking-connection – chain = forward – src-address = 192.168.10.0 – out-interface = WAN – action = mark-connection – new-connection-mark = pcq-con – passtrought = yes

2. marking-packet – chain = forward – connection-mark = pcq-con – action = mark-packet – new-packet-mark = pcq-packet – passtrought = no

Create New Pcq-type

1. >> Queue >> Queue-Type >> add

– name = pcq-download

– kind = pcq

– rate = 32k – limit = 50

– total limit = 2000

– dst-address = yes

Make Queue for Download Traffic

1. >> Queue >> Queue Tree >> add

– name = client-download

– parent = local

– parent-mark = pcq-packet

– queue-type = pcq-download

– priority = 8

## cara sama untuk buat traffic UPLOAD

>> untuk buat pcq with no limit

>> PCQ with no rate

rate = 0

max-limit = 256k

HTB State

*********

1. GREEN >> sama atau kurang dari Limit-at

2. YELLOW >> lebih besar dari Limit-at

3. RED >> melewati Limit-at

>>> attibute HTB

– limit-at

– max-limit

– priority

example for advanced bandwidth management : misal kita beli bandwidth 128kbps atur untuk setiap host untuk dapat bandwidth berapa?

1. buat queue simple parent = total bandwidht yang didapat

Name = TOTAL-BANDWIDTH

max-limit = upload=128k | download=128k

Advance

interface = lan

limit-at = 32k / 32k

2. buat queue untuk host

name = host_A

target address = 192.168.10.5[ip host]

max-limit = 32k / 32k

Advance

interface = lan

limit at = 8k / 8k

queue-type = BAGI-RATA / BAGI-RATA

parent = TOTAL-BANDWIDTH

3. buat pcq connection

name = BAGI-RATA

kind = pcq rate = 16k >> kalo traffic lagi full semua dapet 16k rata

limit= 20

~ oleh nebulagame pada Januari 31, 2009.

11 Tanggapan to “KUMPULAN TUTORIAL MIKROTIK”

  1. terima kasih banyak atas tutornya, bagus banget……sip deh buat anda…maju terus
    ingin sekali belajar lebih jauh dengan anda.
    Ditunggu tutor selanjutnya……
    sekali lagi thanks tutornya….

  2. terima kasih saya ucapkan kepada bapak nandang yang telah memberikan tutorialnya meskipun sasajennya belum saya kirim..

    =)) =))

  3. hatur nuhun bapak nandang blog nya bermanfaat banget hehehe ngan rada lieu si sayah na maklum newbie heheh

  4. gimana bang masalah mikrotik + external proxy apa sudah kelar?
    klo sudah kasih tutornya yach di forum…

    thanks

  5. mas…. minta totorial nya dong…. yang lebih lengkep getoh…
    dari awal setting mikrotic sampe misah2 antara bandwitch buat pesbuk, poker,,, POINT BLANK,,,Donlot….di tunggu ya,,,,,kalo bisa attrach ajj deh ke e mail aku tutor nya….hehehehe….
    kelelawaredan@yahoo.com
    di tungu ya mas…:)

  6. mas dingo maaf ganggu waktunya saya ada masalah berapa hari yang lalu facebook saya sih ok,ok aja setelah saya konfigurasi mikrotik saya sesuai yang mas ajarakan untuk game online dengan queue tree, saat ini yang bermasalah adalah facebook setiap loading page lama banget, setelah saya ping ke http://www.facebook.com baik dari windows maupun dari telnet hasilnya 50% loss kira2 dimana ya masalahnya,mohon bantuannya mas dingo..dari penggemar blog nabula game

  7. tutorial mantap banget mas….ane coba dulu….moga aja berhasil

  8. mas aku lok di tambah screen shotnya tambah mantab nich. aku gi mau belajar masalah Mikrotik mas, talng Software nya, rencanya aku mau buat mikrotik Di CPU P II, cuma aku masih bingun untuk set dari modem-mikrotik-PC User dll

    tlong kirim ma tutorialnya mas di anzascom@yahoo.co.id thanks mas, maaf ngerepotin. mudah2an ilmunya tambah berkah.

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
%d blogger menyukai ini: